You are Here:Home>>Old Posts>>No money to buy Flash CS3, try FlashDevelop 3.0

No money to buy Flash CS3, try FlashDevelop 3.0

Carlos Pinho
By | 2008-02-21T17:35:05+00:00 Feb 21, 2008|Old Posts|
Flash Develop 3.0

Good news for Flash developers – Flash Develop 3.0.0 beta 6 has just been released. The cheapest ActionScript editor out there.

Some of the Features:

* General UI and localization fixes and improvements
* New Bookmarks panel added for an overview of all your open documents bookmarks
* Captures Flash CS3 compiler errors in FD results panel when CS3 is called from FD
* Contextual generators (Ctrl+Shift+1) for getter/setter, event listeners, override methods, interface implementation, unknown var/method
* First class SWC integration in AS3 projects
* New in templates, set package of new project. Creates the main class with the package you provide
* You can run your project in your web browser instead of FD or external player
* Less agressive and generally smarter completion
* Improved Flex Compiler support
* Improved Flash CS3 support


Requirements:

* Java 1.6+ is required for the Flex compiler (ActionScript 3).
* The Flex SDK (2 or 3) is required for ActionScript 3 development if you don’t use Flash CS3.

About the Author:

Carlos Pinho
A father, a husband and a geek... Carlos was the founder of projects like The Tech Labs and Flash Enabled Blog. He is the founder of TekTuts He is passionate about technologies. Their main skills are in analytics, transport & logistics, business administration. He also writes about programming resources, trends, strategy and web development.